Wednesday, March 6, 2013

How to make a bootable USB disk in OS X from an ISO

Use this at your own risk.  I am not responsible if this destroys your USB drive.

Open up a command prompt

Run the following command:

hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/something.iso

Change the first path to where you want to save it "somename.img"

The next piece is where the iso is located. Write the path to where its located.

Type "diskutil list" in the command prompt to get a list of devices.

My USB drive was /dev/disk2.  Yours may be different.

Next you need to unmount the drive.  Type "diskutil unmountDisk /dev/disk2"
*Obviously change that command to what your USB disk is*

Next from the command line run sudo dd if=/yournewimage.img.dmg of=/dev/rdiskN bs=1m

And change rdiskN to what you found from the diskutil.  Mine was rdisk2.

Enter your password and wait.

It looks like nothing is happening but it is.  Just wait longer.  Trust me it will finish.

When it finishes, type diskutil eject /dev/diskN

Again change "N" to the number you used previously.

Reboot and boot from it.


Source: Link


No comments:

Post a Comment

ShareThis